Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 18, 2026 - 14:34 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2026 - 13:00 UTC
Scheduled
A new release to Foodiverse is scheduled to be deployed at 13:00 GMT on Wednesday, 18th March 2026. Thank you for being part of Foodiverse and helping to make a difference!
Posted Mar 18, 2026 - 12:04 UTC
This scheduled maintenance affected: User facing applications (Apps, Website), Donations (Offers via SMS, Donation Processing, Donation Email Receipts), Reporting (Reporting Data), API / Integrations (Customer Integrations), and Call Centre.